Yes, Extendware is compatible with the most recent versions of PHP and backward compatible many versions back.